Issue1036

Title Deeds don't properly localize attribution information
Priority bug Status resolved
Project License Engine Milestone
Superseder Nosy List cwebber, lunpa, nkinkade
Assigned To lunpa Keywords

Created on 2012-04-06.13:33:33 by nkinkade, last changed 2012-07-31.19:21:58 by lunpa.

Messages
msg4002 (view) Author: lunpa Date: 2012-07-31.19:21:57
The problem ended up being that deedscraper determines the appropriate language
by checking for the "lang" attribute in the html node from the deed pages.  I
changed it to look for "xml:lang" as well, and it seems to work correctly now.
msg3996 (view) Author: nkinkade Date: 2012-07-30.20:12:05
Bumping and reassigning this ticket to Lunpa.  This ticket is several months old
now.  CC Korea brought it up back in April, and just brought it back up today.
msg3939 (view) Author: nkinkade Date: 2012-04-06.13:33:32
To reproduce the bug do this:

1) Visit: http://www.cckorea.org/xe/?mid=main
2) Click on the license badge in the footer

The attribution information from the scraper is not localized.  Apparently this
is because the url fetching data from the scraper does not have a lang=
parameter passed to it.  cc.engine should write out a lang= parameter for the
scraper URL that is equivalent to the current language of the deed.
History
Date User Action Args
2012-07-31 19:21:58lunpasetstatus: chatting -> resolved
messages: + msg4002
2012-07-30 20:12:06nkinkadesetstatus: unread -> chatting
assignedto: cwebber -> lunpa
messages: + msg3996
nosy: + lunpa
2012-04-06 13:33:33nkinkadecreate